1

Непонятное поведение 'renderer/update_image_layers'

Topic: Непонятное поведение 'renderer/update_image_layers'

Добрый день!

Использую для получения значений датчиков команду 'unit/calc_sensors'. Для этого соответственно создаю следующую последовательность запросов:

  • renderer/create_image_renderer
  • renderer/create_messages_layer
  • unit/calc_sensors
  • renderer/update_image_layers cо списком слоев на удаление (удаляется слой, созданный на втором шаге)

В приложении все запросы выполняются успешно, значение датчика извлекается. В результате выполнения последней команды, возвращается код результата 0, то есть Wialon отвечает, что все прошло успешно, но при этом в логе 'Error' системы Wialon Pro пишется следующее:

2015/07/24 10:45:35:035: script error in '/var/lib/wialonb3/sites/wialon_sdk/ajax/renderer/update_image_layers.tcl': Invalid operation over 'NULL' object 
2015/07/24 10:45:35:035: SDK AJAX error: user: 'wialon', svc: 'renderer/update_image_layers', params: {"deleteLayers":["sv_layer"],"lang":"ru","rname":"avl-879e5800-0x7f0e1caaa250-0x7f13b2668700","tzOffset":10800}

При этом администраторы системы утверждают, то системе передаются неправильные SDK-запросы. Что же неправильного в таком запросе, при том, что в ответ на него в коде приложения возвращается нуль?

2

Непонятное поведение 'renderer/update_image_layers'

Re: Непонятное поведение 'renderer/update_image_layers'

Добрый день!
Действительно есть небольшой недочёт с нашей стороны. Мы его уже исправили.
Но выпуск обновления pro в ближайшее время не планируется.
Если это произойдёт - Вас уведомят.
Спасибо за замечание.

Head of Wialon Local Department
Gurtam